Ask Your Question
4

Why is the expires_at field in Laravel Sanctum not getting updated?

asked 2022-05-04 11:00:00 +0000

lakamha gravatar image

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2021-05-23 22:00:00 +0000

bukephalos gravatar image

There could be multiple reasons why the expires_at field in Laravel Sanctum is not getting updated. Some possible reasons and solutions are:

  1. Cache issue: Sanctum uses cache to maintain the token state. So, if the cache is not getting cleared or refreshed, it may be causing the expires_at field to not update. Solution: Clear the cache or set a shorter cache duration.

  2. Configuration issue: The configuration settings for Sanctum may not be set correctly. For example, the expiry time may not match the desired duration. Solution: Verify and update the settings in the configuration file.

  3. Code issue: There could be a coding error causing the expiresat field to not update. For example, the code may be manually setting the expiry time without updating the field in the token table. Solution: Review the code and ensure that the expireat field is being updated properly.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account. This space is reserved only for answers. If you would like to engage in a discussion, please instead post a comment under the question or an answer that you would like to discuss

Add Answer


Question Tools

Stats

Asked: 2022-05-04 11:00:00 +0000

Seen: 6 times

Last updated: May 23 '21